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1. Introduction

The quantification of weevil damage on banana corms is an important task when

assessing resistance. In the process of analysing hundreds of samples for weevil damage,

there is an increased likelihood of error especially when using expert visual scoring

observations. This necessitates the need for reliable and objective high-throughput digital

phenotyping methods using analysis tools such as with ImageJ (Elliot et al., 2022).

Accurate and reliable data is essential in crop pathology research and in breeding

programs as they serve as basis to elucidate susceptibility and resistance levels in

breeding germplasm (Li et al., 2020). Digital imaging coupled with computer software

tools provide powerful features for image segmentation, classification, and measurement,

enabling the quantification of weevil damage on banana corms in a precise and efficient

manner.

By utilizing Ilastik's machine learning algorithms and ImageJ’s extensive image

processing capabilities, we can effectively analyse digital images of banana corms

damaged by weevils (Berg et al., 2019; Schneider et al., 2012). The combination of these

tools allows for accurate identification and assessment of damage, as well as the objective

extraction of relevant quantitative measurements for further analysis.
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2. Purpose

To provide a standardized approach for utilizing Ilastik and ImageJ in quantifying weevil

damage on banana corms. By following this procedure, researchers will provide reliable

results in a high throughput way when assessing banana weevil damage.

3. Scope

This SOP covers the following: equipment and software requirements, importing images

to Ilastik, image segmentation using Ilastik, performing batch/group processing on series

of photos in Ilastik using a saved trained project(model), importing an image into ImageJ,

adjusting threshold in ImageJ for assessing banana weevil damage, analysing banana

weevil damage using the "Analyse particles" function in ImageJ, and calculation of

percentage of damaged area from ImageJ particle analysis results.

4. Definition of terms

ImageJ (Fiji): open-source software designed for processing and analysing scientific

images.

Ilastik: open-source software specifically designed for image classification and

segmentation tasks.

Particle analysis: the process of detecting, characterizing, and quantifying objects or

particles within an image.

5. Roles and Responsibilities

Research Technicians/Research Assistants are responsible for corm preparation and

capturing photos of banana corms from the experiment.
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Research Assistants are responsible for analysing banana corm images captured from the

experiment using Ilastik and ImageJ.

Pathologist: Overall supervision and report writing.

6. Procedure/Protocols

Step 1: Equipment and software requirements

● Camera with high-resolution, for example, 10 megapixels or higher to capture

detailed images of the banana corms with weevil damage.

● Computer with Ilastik and ImageJ installed.

● Digital images of banana corms from weevil infested experiments.

Step 2: Corm Preparation and Cutting Procedure

1. Wash the corms with water to remove any soil or debris.

2. Remove the roots from the corms to easy the assessment of damage on the corms.

3. Transversely cut the corms at the collar (pseudostem and corm joint) to obtain

upper cross-section damage.

4. Take photo to capture the upper cross-section damage of the corms.

5. Make further cuts two centimeters below the collar to capture photos of the lower

cross-sectional damage.

Step 3: Image Capturing

1. Capture high-quality images for each genotype using a high-resolution camera.

2. Ensure that the photo file names include the genotype name, block, and plot

number for proper identification.

3. Position the corms against a green background to optimize contrast and minimize

shadows during photography.
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4. Incorporate a ruler as a reference in all images to facilitate accurate measurements

using ImageJ software.

5. Save the resulting images in the Joint Photographic Experts Group (JPEG) format

for future reference and analysis.

Step 4: Importing images and segmentation of images using Ilastik

1. Open Ilastik and create a new project by selecting 'Pixel classification', specifying

a project name.

Figure 1: Creating a new project in Ilastik

2. Import individual images of banana corms into Ilastik by selecting 'Add New' and

choosing 'Add separate image(s)' (Figure 2). Import the desired images from your

computer.
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Figure 2: Importing the photos of banana corms

3. Choose the desired features for analysis by accessing the 'Select features' tab. It is

recommended to include color, intensity, and texture features with a radius of 1.0

px (Figure 3).

Figure 3: Selecting features for analysing the banana corm image
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4. Navigate to the 'Training' tab and create three labels: background, intact corm, and

banana weevil damage. The program will assign colors automatically. Ensure that

the labels are named as illustrated in Figure 4, maintaining the same order for

subsequent analysis.

Figure 4: Adding labels to image for training Ilastik

5. Commence with the training process by selecting a label and annotating the

corresponding regions on the images. The number of images used depends on

how well the selected images represent variations in terms of color, texture for

healthy, damaged and background. This number varies depending on the model’s

accuracy in identifying those regions. Utilize red color to indicate weevil damage,

green for intact corm areas, and yellow for the background (Figure 5). It is crucial

to include multiple corm images for training purposes.
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Figure 5: Training Ilastik by selecting label and annotating corresponding area (red:
weevil damage, green: intact corm areas, yellow: background)

6. Training is essential in ensuring accurate recognition by the program. To evaluate

the effectiveness of the training, click the 'Live update' feature. The program will

display colored regions representing banana weevil damage (red), intact corm

(green), and background (yellow). If the program struggles to differentiate

between these components, click 'Live update' again and uncheck the 'probability'

checkbox. If the program encounters difficulty in distinguishing between these

components, click 'Live Update' again. Then, uncheck the 'probability' checkbox

and add additional labels for background, intact corm, and banana weevil damage

as instructed in point 5 above. Finally, reactivate 'Live Updates' once more.

Step 5: Exporting predictions in Ilastik

1. After training the model, to accurately identify the healthy and damaged regions

in your images, navigate to the "Prediction Export" tab in Ilastik.

2. In the "Export Sources" section, choose "Simple Segmentation" or another

suitable export option based on your requirements.
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3. Proceed to the "Export Settings" section and click on "Choose Settings" or

"Configure" to customize the export settings.

4. Within the export settings, define the file format, file type, and other relevant

parameters to meet your specific needs. For example, you can opt to export

predictions as JPEG files, PNG files, or any supported image format.

5. Specify the desired location for saving the exported predictions by selecting the

appropriate directory or folder.

6. Once you have configured the export settings and chosen the destination folder,

initiate the export process by clicking on the "Export" or "OK" button.

Ilastik will generate and save the exported predictions based on the specified settings and

designated location.

Note: Remember to save your project for use when evaluating additional banana corms

using similar settings in the future.

Step 6: Perform batch processing on series of image in Ilastik using a saved project

1. Open Ilastik and load the saved project file (.ilp) that contains the trained model

and settings you want to use for batch processing.

a. Launch Ilastik on your computer.

b. Go to the File menu and select "Open Project" or use the keyboard

shortcut Ctrl + O.

c. Navigate to the location where the saved project file is located.

d. Select the .ilp file and click "Open" to load the project into Ilastik.

2. Go to the "Batch Processing" tab in Ilastik.

3. In the Batch Processing tab, click on the "Add Input Directory" button or drag and

drop the folder that contains the input images you want to process.
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4. Once the input directory is added, you can specify the output directory where the

processed images will be saved. Click on the "Choose Output Directory" button

and select the desired folder.

5. In the Prediction Export dialogue, configure the processing options as follows: Set

the source to 'Simple Segmentation' and choose the export image settings:

Convert the data type to 'Unsigned 8-bit', set the output file format to JPEG, and

specify the file name format as {dataset_dir}/{nickname}_{result_type}.jpeg.

6. Once you have set up the batch processing options, click on the "Start" or

"Process" button to begin the batch processing.

Attached to this document is the trained Ilastik Project (.ilp) file, which serves as a

pre-trained project for batch processing. This file encapsulates the trained parameters and

methodologies necessary for smooth execution of image analysis tasks without the need

for retraining. By utilizing this trained program, users can efficiently process batches of

images in accordance with the outlined instructions, promoting consistency and

standardization across laboratories.

Step 7: Importing an image into ImageJ

To import an image into ImageJ, follow the steps below as illustrated in Figure 6:

1. Launch ImageJ software on your computer.

2. Go to the "File" menu at the top left corner of the ImageJ window.

3. Select the "Open" option from the drop-down menu.

4. Navigate to the folder where your image is stored.

5. Select the image file you want to import and click on the "Open" button.
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6. The selected image will now be opened and displayed in the ImageJ window.

Figure 6: Importing an image into ImageJ

Alternatively:

a) Use the shortcut "Ctrl + O" (Windows) or "Cmd + O" (Mac) to open the file

directly. or

b) Import an image into ImageJ by dragging and dropping it directly into the ImageJ

window following the steps below:

✔ Open the folder where the image file is located.

✔ Resize the ImageJ window and position it side by side with the folder

window so that both are visible on your screen.

✔ Click and hold the left mouse button on the image file in the folder

window.

✔ Drag the image file over to the ImageJ window.

✔ While still holding the mouse button, move the image file into the ImageJ

window.
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✔ Release the mouse button to drop the image into ImageJ.

✔ The image will be imported and displayed in the ImageJ window.

Note: By dragging and dropping the image, you can quickly import it into ImageJ

without having to navigate through the "File" menu. This method is convenient when the

image file and ImageJ window are visible simultaneously.

Step 8: Adjusting threshold in ImageJ for assessing banana weevil damage

1. Open the ImageJ software and import the image or images generated in Ilastik by

selecting "File" > "Open" or dragging and dropping the image files into the

ImageJ window.

2. Once the image is open in ImageJ, go to the "Image" menu and select "Adjust" >

"Threshold". This will open the Threshold dialog box (Figure 7).

Figure 7: Adjusting threshold in ImageJ

3. In the Threshold dialog box, adjust the threshold to define the range of intensity

values that correspond to the weevil damage (Figure 8).
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Figure 8: Threshold dialog box

4. As you adjust the threshold, you will see a preview of the resulting binary image

where the healthy/intact sections of the corm and the weevil-damaged sections of

the corm are distinguished. Use the preview to fine-tune the threshold until you

are satisfied with the segmentation, ensuring that the healthy corm and the

weevil-damaged corm are appropriately highlighted and separated. This allows

you to segment the damage and analyse it further using tools and functions in

ImageJ (Figure 9).

5. Once you have set the desired threshold, click "Apply" or "OK" button to apply

the threshold to the image.
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Figure 9: Binary image showing the healthy and damaged sections of the same corm.

ImageJ measures the black sections on the image. In photo (A) the black regions

represent the healthy sections of the corm while in photo (B) they represent the sections

damaged by weevils.

Step 9: Analysing weevil damage using the "Analyse Particles" function in ImageJ

After setting the threshold in ImageJ the next step is to use the "Analyse particles"

function.

1. Selecting an image for which threshold has been set: After setting the threshold,

ensure that the image whose threshold has been determined (the binary image

where the damaged areas are highlighted) is active or selected in the ImageJ

interface.

2. Open the Analysis Menu: Go to the "Analyse" menu in the ImageJ menu bar.

3. Selecting "Analyse particles": From the "Analyse" menu, choose the "Analyse

particles" option. This action will open the "Analyse particles" dialog box (Figure

10).
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Figure 10: Selection of analyse particles in ImageJ.

4. Setting particle size parameters: In the "Analyse particles" dialog box, specify the

criteria for the size of the particles to be analyzed, such as, minimum, and

maximum particle size, circularity, and other parameters. Adjust settings based on

the specific requirements (Figure 11).
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Figure 11: Setting particle size parameters

5. Choosing particle output options: In the same dialog box, select the desired output

options for the analysed particles to include displaying the results in the "Results"

window, generating a summary, or overlaying the results on the image.

6. Running the analysis: Once the particle size parameters are set, chose the output

option and click the "OK" button in the "Analyse particles" dialog box to initiate

the analysis process, where ImageJ analyses the images whose threshold has been

set based on the specified criteria.

7. Reviewing the analysis results: Once analysis is completed, results are displayed

in the "Results" window. Detected particle size, shape, and other measurements

are shown. You can review and further analyse these results as per your analysis

requirements (Figure 12).
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Figure 12: Review of the Analysis Results

Step 10: Recording a Macro for Batch Processing in ImageJ Fiji

1. Open the ImageJ Fiji software on your computer.

2. Load the image on which you intend to perform your desired operations.

3. Start Recording Macro by navigating to the "Plugins" menu, then select "Macros"

and choose "Record...".

4. Execute the desired operations, from step 8 to step 9 above, to be recorded in the

macro.

5. Save the macro by Copying and saving it in a text editor like Notepad at your

desired location.
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Step 11: To Utilize the Saved Macro

1. Install the macro by Navigating to "Plugins,” then "Macros," and select "Install."

Browse to the location where the macro is saved and choose it. Once installed, the

recorded macro will appear in the macros window when opened.

2. Using the macro: Import the image into ImageJ and then run the saved macro to

obtain results without needing to repeat steps 8 to 9 again.

Step 12: Calculating percentage of damaged area from ImageJ particle analysis

results

1. Open the particle analysis results in ImageJ.

2. Identify measurements representing damaged and healthy area. This could be an

area measurement, such as "Area" or "Area fraction" in the results table.

3. Sum up the values of the damaged and health area measurements for all the

particles detected to obtain total area of the analysed image or region of interest.

4. Divide the sum of all measurements of the damaged area by the total area and

multiply by 100 to obtain the percentage damaged area.

5. ImageJ generates results with the genotype's corresponding name, along with

details such as plot number, row, and column appended to the image file name.

These results are subsequently transferred to an Excel worksheet, where they can

be arranged based on genotype and experimental block layout. The Excel

worksheet is converted into a Musabase template for uploading to Musabase.

Note:

1) Specific names of the measurements may vary depending on the settings and

analysis performed in ImageJ.
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2) It is important to identify the correct measurements representing the damaged area

in your particle analysis results.
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8. Annex: Forms/Templates to be used for monitoring and data collection

Digital data collection at
Termination of experiment

1. Set the scene to capture corm samples on a green

background.

2. Capture images with high resolution.

3. Transfer images from camera and backup on the computer.

Software installation Install Ilastik and ImageJ on computer.

Image analysis Analyse captured images using Ilastik and ImageJ
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